Resolved
We've identified the issue and implemented a fallback so chat threads should now be generating correctly.
Investigating
New threads in Granola Chat aren't getting auto-generated titles as we would expect. We're looking into why this is and will deploy a fix shortly.