No components marked as affected
Resolved
We've rolled back a change which has resolved this issue. Thanks for bearing with us.
Investigating
We've noticed an issue related to links to notes being shared, where users are seeing 'Note not found' despite the sharing settings being enabled. We're investigating.