Resolved
Working together with Apple we have resolved this issue. The iOS app is once again available for download on the AppStore.
Investigating
Currently the Granola iOS app is unavailable on the AppStore for updates and new installs. We are working with Apple to resolve this issue.